
Importing is one of the timesaving features of Standard & Poor’s Research Insight. You can use
the Task Scheduler to import or download files during your off-hours and optimize the time you
spend at the office.

You can also incorporate your own data, companies and concepts into Research Insight directly
from any application that can create a delimited ASCII file.

This chapter shows you how to

• use the Task Scheduler

• import data into Research Insight

• import sets into Research Insight

• import concepts into Research Insight
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Using the Task Scheduler
Note: For network users. Only Network Administrators should use this feature. For further

network usage recommendations, please refer to “Sharing Databases on a Network” in
Standard & Poor’s Research Insight Beyond Basics manual.



You will see the Schedule Import dialog box.

4. Select User Data, User Sets or Economic Data from the Define Import area.

Hint: Click the Browse button and select the drive and directory where the file is stored.
This information will be reported in the source field.

5. Click the Text Options button. You will see the Text Options dialog box.

6. Select the column delimiter type used in the import file and click OK. The column 
delimiters are as follows:

Tab Delimits columns with tabs.
Comma Delimits columns with commas.
Space Delimits columns with spaces.
Semicolon Delimits columns with semicolons.
Custom Delimits columns with a custom character.
Use Quotes Encloses text with quotes.
Use Labels Includes labels at the top of each column.
Fixed Field Delimits columns with a specified number of spaces. Enter the number

of spaces you want your columns separated by in the text box.

Hint: If you select the Use Labels option, Research Insight will include labels at the top of
each column in a table report, but not in a free-form report.
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7. If you like, enter a description of your file in the Description field.
8. Schedule your import. Select either Now, One Time, Upon New Data File or 

Periodically from the Schedule area of the Schedule Import dialog box.

Now Research Insight will import your file as soon as you close the Task 
Scheduler.

One Time Research Insight will import your file at a specific date and time. Once 
you select this option, you will be able to select the date and time you 
want your file imported.

Upon New At startup, Research Insight will look for a more current data file 
Data File compared to the date of the file at setup time, or compared to the last 

data file imported. Once you select this option, you will be able to 
specify the time that you want Research Insight to begin searching for 
a new file.

Periodically Research Insight will import your file either daily, weekly, or monthly at 
a specific time. Once you select this option, you will be able to schedule 
the time you of day you want your file imported and the date you want 
the import to begin.

9. When you are satisfied with your selections, click OK.You will return to the Task Scheduler dialog box. The import you just scheduled will appearin alphabetical order in the list of Scheduled Tasks.

Hint: When you schedule multiple tasks, Research Insight will import files according to the
order of the time scheduled, regardless of the length of time needed to import each file.
For example, if you schedule one import at 11:00 p.m. and another at 11:15 p.m., and
the first import takes 20 minutes, Research Insight will import the second task
immediately after the first task is finished.

10. When you are finished scheduling imports, close the Task Scheduler dialog box.

Important: In order to import data, Research Insight must be running, so do not close
Research Insight if you have an import scheduled.
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Changing the Import Schedule
From time to time, you may want to alter the import schedule previously established. Research
Insight makes changing this schedule a simple process.

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to change and click the Update Task button.
You’ll see the Schedule Import dialog box.

3. Make your changes to the import schedule and click OK.
You will return to the Task Scheduler dialog box. The import you just rescheduled will 
appear in alphabetical order in the list of Scheduled Tasks.

4. When you are finished scheduling imports, close the Task Scheduler dialog box.

Important: Research Insight must be running in order to import data.
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Scheduling an Internet Download
Research Insight makes it easy for you to schedule a download for fundamental and Value 
Added data from the Internet.

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Click the New Task button.
You will see the New Schedule Entry dialog box.

3. Click the Internet Download radio button and click OK.
You will see the Schedule Internet Download dialog box.

4. Select the file or files you want to download from the File Types area. These files are 
described below.

Daily Prices Contains market data such as daily prices, adjustment factors, 
common shares traded, and dividends per share.

Fundamentals Contains fundamental company information such as sales, net 
income and operating earnings per share. Also contains 
fundamental financial data, per share data and ratios for the
S&P indexes.

Value Added Data The Value Added database consolidates the sector, economic 
sector, non-active sector and Value/Growth Indicator files. It 
also includes IPO Date, Industry Sector Code–Historical, 
Economic Sector Code—Historical, Index Fundamentals, 
Insider Trading and Institutional Ownership data items.
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FIRST CALL Contains two quarters and two fiscal years of FIRST CALL
Consensus consensus earnings estimate data, expected report dates, 

consensus recommendations, future growth rates, earnings 
surprise data, operating actual earnings, and P/E ratios.

FIRST CALL Contains earnings estimate consensus trends and estimate 
Revisions revision momentum.
COMPUSTAT(Classic) Contains non-restated, quarterly COMPUSTAT data 

as it was originally collected by Standard & Poor’s.
EVAntage Contains Stern Stewart’s proprietary EVA model data.

5. Specify the number of days worth of data you want to download or select the All days
needed



Establishing Your Internet Settings
In order to download data, you need to have a connection to the Internet. The first time you
open the Schedule Internet Download dialog box, Research Insight will ask for your User Name
and Password. You may also need to enter proxy settings, depending on whether you access the
Internet through a firewall at your organization (check with your organization’s Network
Administrator).

The Internet Download Settings dialog box is shown below.

Changing the Internet Download Schedule
From time to time, you may want to alter the Internet download schedule previously
established. 

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to change and click the Update Task button.
You will see the Schedule Internet Download dialog box.

3. Make your changes to the download schedule and click OK.
You will return to the Task Scheduler dialog box. The download you just scheduled will 
appear in alphabetical order in the list of Scheduled Tasks.

4. When you are finished scheduling downloads, close the Task Scheduler dialog box.

Important: Research Insight must be running in order to download data.
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Suspending a Scheduled Task
When a task is suspended, all of the scheduling information is saved and can be activated again.

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to suspend and click the Activate/Suspend button.
The Task Scheduler suspends the highlighted task from the list of scheduled tasks. To
activate this task again, simply highlight the task and click the Activate/Suspend button.

3. When you are finished, close the Task Scheduler dialog box.

Deleting a Scheduled Task
Once you decide that you have no further need for a scheduled task, you can delete it from the
list of scheduled tasks.

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to delete and click the Delete Task button.
Research Insight asks if you are sure you want to delete the selected tasks.

3. Click Yes.
The Task Scheduler deletes the highlighted task from the list of scheduled tasks.

4. When you are finished, close the Task Scheduler dialog box.
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Viewing Import and Download Results
For your convenience, the Task Scheduler records all completed activities in a log file. This file
shows you information such as the name of the file imported or downloaded, and the date and
time the import or download started and finished.

Begin from the Research Insight desktop.

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Click the View Log button.
You will see the Schedule.log file.

3. When you are finished viewing the import or download results, select Exit from the 
File menu.
You will return to the Task Scheduler dialog box.

4. When you are finished, close the Task Scheduler dialog box.
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Importing Your Own Data into Research Insight
You can use the importing feature to incorporate data items and values into Research Insight.
This section shows you how to import data from a delimited ASCII file into Research Insight.

There are three steps involved in importing your own data: creating your spreadsheet file, saving
and importing the data from your spreadsheet file into Research Insight.



Importing Your Data
After creating a delimited ASCII file, you are ready to import the data into Research Insight.
The data you import will be loaded into the write-to database. (For more information on write-
to databases, see “Managing Your Databases” in Standard and Poor’s Research Insight Beyond
Basics manual.) The file you are importing must be closed before you proceed.

Begin from the Research Insight desktop.

1. From the File menu, select Import. 
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 
4. Ensure that the Data radio button is selected. 
5. Click Open to import the file.
6. Click OK when Research Insight displays a message asking you to confirm that the file is

comma separated.

If you saved your spreadsheet as a comma separated file with the .csv extension (comma
separated values), Research Insight displays a message asking you to confirm that the file is
indeed comma separated. If so, click OK. If not, click NO and select the delimiter used
for the file.

A new window will briefly display an import progress bar, the write-to database, the type of 
retrieval key used and the items being imported. Research Insight will tell you when the 
processing is complete.

Hint: An import error file (import.err) is created if an import attempt is unsuccessful. This file
explains what needs to be corrected to import successfully.
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Importing Sets Into Research Insight
This section shows you how to import your own sets from an Excel spreadsheet into Research
Insight. Sets imported into Research Insight must be in a delimited file.

There are two steps involved in importing sets: creating your spreadsheet file and importing the
set from your spreadsheet file into Research Insight.

Creating Your Spreadsheet
To create your spreadsheet file, open a new document in Excel. Create the table header in the
first row. The header must contain a retrieval key, such as a ticker symbol. An example is shown
below.

Next, fill in the company identifiers in cell A2 and down.

We recommend that you save your file as a comma separated values file (*.csv file). After saving
your file, close your spreadsheet application. You are ready to import your set into Research
Insight.

Importing Your Set
Once you have completed your spreadsheet, you are ready to import your set. The set you
import will be added to the write-to database.

Begin from the Research Insight desktop.

1. From the File menu, select Import.
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 
4. If you want to import a file delimited by anything other than commas or tabs, click the 

Text Options button, select your column delimiter and click OK.
5. Ensure that the Set radio button is selected. 
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6. Click Open to import the file.
Research Insight displays a message asking you to confirm that the file is a comma 
separated values file. If so, click OK. If not, click NO and select the delimiter used 
for the file.
The Set Type dialog box appears.

7. Select the type of set you want to import. If your spreadsheet contains company ticker 
symbols, you can still choose to import the companies as a Business Segment set, 
geographic segment set or issue set. The retrieval keys in the spreadsheet don’t have to 
match the set type you choose.

8. Click OK.
A window will briefly display an import progress bar, the write-to database, the type of 
retrieval key used and the items being imported.

Hint: An import error file (import.err) is created if an import attempt is unsuccessful. This file
explains what needs to be corrected to import successfully.

The imported set appears on your screen in a spreadsheet format.

9. From the File menu, select Save to save the file as a set.
You will see the Save As dialog box.

10. Enter the set name in the File Name text box.
11. Click Save. Your file is now saved as a set.
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Importing Concepts Into Research Insight
This section shows you how to import concepts into Research Insight. The Import feature
makes it easy to share your concepts with your colleagues. You can create concepts in Research
Insight and export them so they can be imported back into another Research Insight system.
The concepts you import will be added to the write-to database. 

Begin from the Research Insight Desktop.

1. From the File menu, select Import.
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 
4. If you want to import a file delimited by anything other than commas or tabs, click the

Text Options button, select your column delimiter and click OK.
5. Ensure that the Concepts radio button is selected. 
6. Select the Concept radio button in the lower right corner and click Open.

The Import Concepts dialog box appears.

7. Select the concepts you want to import in the From list box and click Add. 
8. Click Accept.

Research Insight informs you when processing is complete.
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