


Scheduling Imports and Downloads With the Task
Scheduler

The Task Scheduler was designed to save you time when importing or downloading large files into
Research Insight. You can import your own files or download files from the Internet. All you have
to do is specify which files you want to import or download and the date and time you want the
task performed. The Task Scheduler does the rest. The files you import or download will be added
to the write-to databases (For more information on write-to databases, see the Managing Your
Databases chapter of the Standard and Poor’s Research Insight Beyond Basics manual). 

Note: For network users only: only Network Administrators should use this feature. For further
network usage recommendations, please refer to the Sharing Databases on a Network
chapter of the Standard & Poor’s Research Insight Beyond Basics manual.

Scheduling an Import
Research Insight makes it easy for you to schedule an import for your own files.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Click the New Task button.
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You will see the New Schedule Entry dialog box.

3. The Import radio button should be selected by default, so simply click OK.
You will see the Schedule Import dialog box.

4. Select either User Data or User Sets from the Define Import area.

Hint: Click the Browse button and select the drive and directory where the file is stored.

5. Click the Text Options button.
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You will see the Text Options dialog box.

6. Select the column delimiter type used in the import file and click OK. The column 
delimiters are as follows:

Tab Delimits columns with tabs.
Comma Delimits columns with commas.
Space Delimits columns with spaces.
Semicolon Delimits columns with semicolons.
Custom Delimits columns with a custom character.
Use Quotes Encloses text with quotes.
Use Labels Includes labels at the top of each column. 
Fixed Field Delimits columns with a specified number of spaces. Enter the number 

of spaces you want your columns separated by in the text box.

Hint: If you select the Use Labels option, Research Insight will include labels at the top of
each column in a table report, but not in a free-form report.

7. If you like, enter a description of your file in the Description field.
8. Schedule your import. Select either Now, One Time, Upon New Data File, or 

Periodically from the Schedule area of the Schedule Import dialog box.

Now Research Insight will import your file as soon as you close the Task 
Scheduler.

One Time Research Insight will import your file at a specific date and time. Once 
you select this option, you will be able to select the date and time you 
want your file imported.

Upon New At startup, Research Insight will look for a more current data file 
Data File compared to the date of the file at setup time, or compared to the last 

data file imported. Once you select this option, you will be able to 
specify the time that you want Research Insight to begin searching for 
a new file.
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Periodically Research Insight will import your file either daily, weekly, or monthly at 
a specific time. Once you select this option, you will be able to schedule 
the time of day you want your file imported and the date you want 
the import to begin.

9. When you are satisfied with your selections, click OK.
You will return to the Task Scheduler dialog box. The import you just scheduled will appear
in alphabetical order in the list of Scheduled Tasks.

Hint: When you schedule multiple tasks, Research Insight will import files according to the
order of the time scheduled, regardless of the length of time needed to import each file.
For example, if you schedule one import at 11:00 p.m. and another at 11:15 p.m., and
the first import takes 20 minutes, Research Insight will import the second task
immediately after the first task is finished.

10. When you are finished scheduling imports, close the Task Scheduler dialog box.

Important: In order to import data, Research Insight must be running, so do not close
Research Insight if you have an import scheduled.

Changing the Import Schedule
From time to time, you may want to alter the import schedule previously established. Research
Insight makes changing this schedule a simple process.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to change and click the Update Task button.



You’ll see the Schedule Import dialog box.

3. Make your changes to the import schedule and click OK.
You will return to the Task Scheduler dialog box. The import you just rescheduled will 
appear in alphabetical order in the list of Scheduled Tasks.

4. When you are finished scheduling imports, close the Task Scheduler dialog box.

Important: Research Insight must be running in order to import data.

Scheduling an Internet Download
Research Insight makes it easy for you to schedule a download for cash flow and fundamental
data from the Internet.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Click the New Task button.
You will see the New Schedule Entry dialog box.

3. Click the Internet Download radio button and click OK.
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You will see the Schedule Internet Download dialog box.

4. Select the file or files you want to download from the File Types area. These files are 
described below:

Cash Flow Contains cash flow items for international companies (non-U.S.
and Canadian).

Fundamentals Contains fundamental company information such as sales, net 
income, and operating earnings per share for rest-of-world 
companies.

5. Specify the number of days worth of data you want to download or select the All days
needed option. This option is selected by default and automatically downloads the
appropriate number of days worth of data necessary to complete your cash flow or
fundamental data file.

6. Schedule the time you want your file downloaded. Select either Now, One Time, or
Periodically from the Schedule area of the dialog box.

Now Research Insight will download your file as soon as you close the Task 
Scheduler.

One Time Research Insight will download your file at a specific date and time. 
Once you select this option, you will be able to schedule the date and 
time you want your file downloaded.

Periodically Research Insight will download your file either daily, weekly, or monthly 
at a specific time. Once you select this option, you will be able to 
schedule the time you of day you want your file downloaded and the 
date you want the download to begin.

7. When you are satisfied with your selections, click OK.
You will return to the Task Scheduler dialog box. The download you just scheduled will 
appear in alphabetical order in the list of Scheduled Tasks.



Hint: When you schedule multiple downloads, Research Insight will download files according
to the order of the time scheduled, regardless of the length of time needed to download
each file. For example, if you schedule one download at 12:00 a.m. and another at 12:15
a.m., and the first download takes 20 minutes, Research Insight will download the second
task immediately after the first task is finished.

8. When you are finished scheduling downloads, close the Task Scheduler dialog box.

Important: In order to download data, Research Insight must be running, so do not close
Research Insight during the time that the download is scheduled.
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Establishing Your Internet Settings
In order to download data, you need to have a connection to the Internet. The first time you
click on the Schedule Internet Download dialog box, Research Insight will ask for your user
name and password. You may also need to enter proxy settings, depending on whether you
access the Internet through a firewall at your organization (check with your organization’s
Network Administrator).

The Internet Settings dialog box is shown below:

Changing the Internet Download Schedule
From time to time, you may want to alter the Internet download schedule previously
established. Research Insight makes changing this schedule a simple process.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to change and click the Update Task button.
You will see the Schedule Internet Download dialog box.

3. Make your changes to the download schedule and click OK.
You will return to the Task Scheduler dialog box. The download you just scheduled will 
appear in alphabetical order in the list of Scheduled Tasks.

4. When you are finished scheduling downloads, close the Task Scheduler dialog box.

Important: Research Insight must be running in order to download data.



Suspending a Scheduled Task
This section shows you how to temporarily suspend a scheduled task. When a task is suspended,
all of the scheduling information is saved and can be activated again. 

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to suspend and click the Activate/Suspend button.
The Task Scheduler suspends the highlighted task from the list of scheduled tasks. To 
activate this task again, simply highlight the task and click the Activate/Suspend button.

3. When you are finished, close the Task Scheduler dialog box.

Deleting a Scheduled Task
Once you decide that you have no further need for a scheduled task, you can delete it from the
list of scheduled tasks.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Highlight the task you want to delete and click the Delete Task button.
Research Insight asks if you are sure you want to delete the selected tasks.

3. Click Yes.
The Task Scheduler deletes the highlighted task from the list of scheduled tasks.

4. When you are finished, close the Task Scheduler dialog box.
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Viewing Import and Download Results
For your convenience, the Task Scheduler records all completed activities in a log file. This file
shows you information such as the name of the file imported or downloaded, and the date and
time the import or download started and finished.

Begin from the Research Insight desktop:

1. From the Tools menu, select Task Scheduler.
You will see the Task Scheduler dialog box.

2. Click the View Log button.
You will see the schedule.log file.

3. When you are finished viewing at the import or download results, select Exit from the 
File menu.
You will return to the Task Scheduler dialog box.

4. When you are finished, close the Task Scheduler dialog box.



Importing Your Own Data into Research Insight
You can use the importing feature to incorporate data items and values into Research Insight.
This section shows you how to import data from a delimited ASCII file into Research Insight.

There are two steps involved in importing your own data: creating your spreadsheet file and
importing the data from your spreadsheet file into Research Insight.

Creating Your Spreadsheet
To create your spreadsheet file, open a new document in Excel. Create the table header by
entering labels in the first row of the spreadsheet. First, enter the retrieval key (e.g., ticker
symbol) in cell A1. The different types of retrieval keys you can use are listed below. Then in
cells B1 and across, enter item mnemonics recognized by Research Insight with valid time
periods. An example is given below.

Now you're ready to fill in the data you want to evaluate in your spreadsheet. In cells A2 and
down, enter company identifiers (if you chose ticker symbol for the retrieval key, then enter
company tickers). In cells B2 and beyond, enter the data that corresponds to the data item
mnemonic, the time period and the specific company ticker in each cell. An example is given
below.

Retrieval Keys

Valid retrieval keys include:

TIC The company’s ticker symbol.
CUSIP The company’s CUSIP number, a 9-digit number.
GVKEY The company’s GVKEY in the COMPUSTAT (Global) database.
Currency Key A currency key used in the Global database.

If you want to import an Issue, Business Segment or Geographic Segment, enter the ticker
symbol, a back slash, the appropriate segment letter and two-digit segment identifier. For
example, to import data for the Domestic Geographic segment of the Mirage Hotel and Casino,
you would use MIR\G01 as the ticker symbol.
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Mnemonics

Valid mnemonics will match mnemonics from the data dictionary of the active database group.

Saving Your File

In order for Research Insight to read your import file, it needs to be saved as a .csv (Comma
Separated Values) file. To save as a .csv file:

1. Choose Save As from the Excel File menu.
2. Select a location to save your import file.
3. Name your import file.
4. From the Save As Type drop-down menu, choose .csv (Comma Delimited)
5. Click Save.

After saving the file, close your spreadsheet application. You’re ready to import your data into
Research Insight.

Importing Your Data
After creating a delimited ASCII file, you are ready to import the data into Research Insight.
The data you import will be loaded into the write-to database (For more information on write-to
databases, see the Managing Your Databases chapter of the Standard and Poor’s Research Insight
Beyond Basics manual). The file you are importing must be closed before you proceed.

Begin from the Research Insight desktop:

1. From the File menu, select Import. 
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 



4. Ensure that the Data radio button is selected. 
5. Click Open to import the file.
6. Click OK when Research Insight displays a message asking you to confirm that the file is 

comma separated.

A new window will briefly display an import progress bar, the write-to database, the type of 
retrieval key used, and the items being imported. Research Insight will tell you when the 
processing is complete. An import error file (import.err) is created if an import attempt is 
unsuccessful. This file explains what needs to corrected to import successfully.

Hint: An import error file (import.err) is created if an import attempt is unsuccessful. This file
explains what needs to be corrected to import successfully.
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Importing Sets into Research Insight
This section shows you how to import your own sets from an Excel spreadsheet into Research
Insight. Sets imported into Research Insight must be in a delimited ASCII file.

There are two steps involved in importing sets: creating your spreadsheet file and importing the
set from your spreadsheet file into Research Insight.

Creating Your Spreadsheet
To create your spreadsheet file, open a new document in Excel. Create the table header in the
first row. The header must contain a retrieval key, such as a ticker symbol (mnemonic TIC). An
example is shown below:

Next, fill in the company identifiers in cell A2 and down.

We recommend that you save your file as a Comma Separated Values file (*.csv file). After saving
your file, close your spreadsheet application. You are ready to import your set into Research Insight.

Importing Your Set
Once you have completed your spreadsheet, you are ready to import your set. The set you
import will be added to the write-to database. 

Begin from the Research Insight desktop:

1. From the File menu, select Import.
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 
4. If you want to import a file delimited by anything other than commas or tabs, click the 

Text Options button, select your column delimiter and click OK.
5. Ensure that the Set radio button is selected. 
6. Click Open to import the file.

Research Insight displays a message asking you to confirm that the file is a Comma 
Separated Values file. If so, click OK. If not, click NO and select the delimiter used for the 
file.

Chapter 9 - Importing and Downloading

125



The Set Type dialog box appears.

7. Select the type of set you want to import. If your spreadsheet contains company tickers, you
can still choose to import the companies as a business segment set, geographic segment set, 
or issue set. The retrieval keys in the spreadsheet don’t have to match the set type you 
choose.

8. Click OK.
A window will briefly display an import progress bar, the write-to database, the type of 
retrieval key used, and the items being imported.

Hint: An import error file (import.err) is created if an import attempt is unsuccessful. This file
explains what needs to be corrected to import successfully.

The imported set appears on your screen in a spreadsheet format.

9. From the File menu, select Save to save the file as a set.
You will see the Save File dialog box.

10. Enter the set name in the File Name text box.
11. Click Save.

Your file is now saved as a set.
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Importing Concepts into Research Insight
This section shows you how to import concepts into Research Insight. The Import feature
makes it easy to share your concepts with your colleagues. You can create concepts in Research
Insight and export them so they can be imported back into another Research Insight system. 
The concepts you import will be added to the write-to database. 

Begin from the Research Insight Desktop:

1. From the File menu, select Import.
You will see the Import dialog box.

2. Select the drive and folder where the file you want to import is located.
3. Enter the name of the file you want to import in the File Name field or select it from 

the list box. 
4. If you want to import a file delimited by anything other than commas or tabs, click the 

Text Options button, select your column delimiter and click OK.
5. Ensure that the Concepts radio button is selected. 
6. Select the Concept radio button in the lower right corner and click Open.

The Import Concepts dialog box appears.

7. Select the concepts you want to import in the From list box and click Add. 
8. Click Accept.

Research Insight informs you when processing is complete.
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